Autel Support Communities
Autel Support Communities
Welcome, Guest     Sign in
Communities > Diagnostics > Europe Cars > My MD808Pro will not update as it's aski...
My MD808Pro will not update as it's asking for v1.4 to be installed ???

359 Views 1 Replies Latest reply: 2023-06-06 10:51:04


  •   Level 1   
    (5) points
    ukTerenceauto
    2023-06-05 18:49:44
     Trying to scan my car but my MD808 Pro is asking for V1.4 to be installed first. How and where do I install V1.4 ??

    Tags: problem


  •   Level 9   
    (3264) points

    2023-06-06 10:51:04 (Reply to:ukTerenceauto)

    Hi visit you tube to find instruction video from Autel how to do this.
1
  Total1 Pages