Autel Support Communities
Autel Support Communities
Welcome, Guest     Sign in
Communities > TPMS > TS501 > Actually a TS508 Issue
Actually a TS508 Issue

1536 Views 4 Replies Latest reply: 2023-06-14 15:23:51


  •   Level 1   
    (5) points
    Greg Swartz
    2021-11-28 16:29:22
    So,  I purchased this TS508 and downloaded the Maxi PC Suite V1.12 for MAC and downloaded the updates.   All the updates downloaded except this one:
    TS508US/EU (Software Name) TS508_GL (Software Kit) V1.80 (Version).

    So,  I decided to try the handheld on the 2019 Subaru Crosstrek that I just put the winter tires on.

    I was able to trigger them and identify them.   When I used the OBD Cable,  the error that came accross the handheld was "Read ID's Not Support".  Then,  "READ ID's Failed",  "Read DTC's Failed"

    Not sure what the issue is,  but this is an expensive device,  and I cannot for the life of me understand what went wrong.
    file:  

  •   Level 2   
    (20) points
    jtr990

    2022-01-28 06:27:21 (Reply to:Greg Swartz)

    Do you have a Windows PC with you (or in the case of the Mac you're using, Boot Camp for Windows)? If so, try downloading the latest Maxi PC Suite and update the tool again. I'm on version 1.32 and I was able to update my TS508 completely, including TS508US/EU TS508_GL V1.82.

  •   Level 1   
    (6) points
    ARTUR NIEDZIELA

    2023-02-21 22:06:42 (Reply to:jtr990)

    A mi powiedz, jak dokonać aktualizacji jak to zrobić według instrukcji robię i po podłączeniu do PC nie widać, że dodano urządzenie tylko samo ładowanie ts508. Czy to przewodu USB czy urządzenie TS508.

  •   Level 1   
    (3) points

    2023-03-10 22:10:28 (Reply to:ARTUR NIEDZIELA)

     W urzadzeniu wejdz my device i update, wtedy polaczys sie z komputerem

  •   Level 1   
    (6) points
    Jody Bryant

    2023-06-14 15:23:51

     Not sure if you are still experiencing this, but I recently purchased a TS508WF and experienced the same thing on an M1 Macbook Air. I was able to get it to update by selecting all packages and uninstalling them and then letting it reinstall all of them and it worked. Not sure if that will solve it for you but that worked for me so maybe it will help.
1
  Total1 Pages